Como instalar Avast 4 para Linux en Ubuntu 9.10

Si. Linux no se infecta, lo sé. Pero la vez pasada me pasó algo muy curioso. Resulta que la razón por la cual uso Ubuntu es porque me cayó una infección viral en XP que ni les cuento!

En resumen, formateé mi disco principal y dejé Ubuntu como mi sistema operativo de preferencia. Luego un día, me puse a editar el sitio de mi cuñado y… ¡oh sorpresa! El sitio fue “cerrado” por Google. Si, pueden hacerlo. Al menos, te ponen un letrerón en los resultados de búsqueda que te avisa que tu sitio infecta al que pase por ahi. Y Firefox no te deja entrar tampoco, basado en la información provista por Google.

Eran archivos infectados que habían quedado en las particiones ntfs y que yo no había revisado contra virus 🙁

Así que me puse a buscar y encontré que Avast Antivirus 4 tiene una versión para Linux.

Hasta aquí todo bien. Pero cuando armé una nueva PC y le metí Ubuntu 64 bits, el Avast súbitamente no funciona. Pero lo bueno de usar Ubuntu es que encuentras casi de todo en soluciones. Lo malo es que usualmente está en inglés, por lo cual una gran cantidad de hispanoparlantes se queda sin el conocimiento…

Así que aquí plasmo la explicación de cómo instalar Avast 4 en Ubuntu 9.10 64-bit. Esta información fue sacada de: http://ubuntuforums.org/showthread.php?t=781251 y en mi caso, funcionó perfectamente; estoy utilizando Avast 4 sin problemas.

Veamos:

  1. Lo primero es instalar el paquete ia32-libs si no lo tienes ya instalado. Abre la terminal y escribe lo siguiente:
  2. sudo apt-get install ia32-libs

  3. Ahora, baja el paquete Debian de Avast aqui y guárdalo en tu escritorio. Las instrucciones que siguen asumen que lo guardaste allí.
  4. Cuando lo hayas bajado, cambia a tu escritorio.
  5. cd /home/TuUsuario/Escritorio

  6. Instala el paquete deb de Avast:
  7. sudo dpkg --force-architecture -i avast4workstation_1.3.0-2_i386.deb

  8. Ahora tenemos que asegurarnos que todas las librerías necesarias están en tu directorio /usr/lib32. Para simplicar esto, subí un paquete de librerias para Avast hecho por “linuxed”. Baja este archivo a tu escritorio también y ejecuta este comando:
  9. sudo dpkg -i ia32-avast-libs.deb

  10. Luego que los paquetes han sido instalados, tenemos que asegurarnos que todas las librerías requeridas están presentes. Escribe lo siguiente:
  11. ldd /usr/lib/avast4workstation/bin/avastgui
    ldd /usr/lib/avast4workstation/bin/avast

  12. Revisa ambas listas y fíjate que ninguno de los renglones diga “Not Found”. Si ninguno lo dice, ya debes poder correr Avast desde el menú de aplicaciones.

Si en algún momento quieres desinstalar este paquete, abres la terminal y tecleas lo siguiente:
       sudo apt-get remove avast4workstation

Comments

  1. Muchisimas gracias, me ha sido de gran ayuda!!! No encontraba la manera de hacerlo funcionar en mi ubuntu x64. Mil gracias

  2. Hola David,

    Me alegro que te haya sido de utilidad.

  3. hola, que tal oye quisiera preguntarte hacerca de esta instalacion, cuando mecionas que hay que cambiar al escritorio que es lo que tengo que hacer, no entiendo muy bien esta parte. Gracias

  4. Lo que debes ahcer es asegurarte que estas en el escritorio al abrir tu ventana de terminal. Si no lo haces, no podras instalar el paquete que guardaste en el escritorio.

  5. He estado leyendo con atención tu explicación, que la verdad es de las más completas que he visto.
    Mi problema es el siguiente, tengo Ubuntu 10.04 y en otra partición windows con algún virus que me impide ejecutarlo bien, y aunq le estoy pillando el gustillo a ubuntu me gustaria utilizar windows alguna vez (por ejemplo para imprimir a doble cara con una samsung q en ubuntu no puedo)
    He intentado instalar el Avast para ubuntu de varias maneras.
    La primera bajando el .deb directamente de la web de Avast, lo instala pero cuando lo intento ejecutar aparece: Argumento invalido.
    Lo he intentado de la marera que explicas tu: Instalo a traves de la terminal el .deb, termina diciendo: Procesando disparadores para man-db.
    Luego he intentado lo de las librerias y dice:
    dpkg: error al procesar ia32-avast-libs.deb (–install):
    la arquitectura del paquete (amd64) no corresponde con la del sistema (i386)
    Se encontraron errores al procesar:
    ia32-avast-libs.deb

    Y ahí me quedo…si pudieras ayudarme te lo agradecería mucho, y sino tambien. Gracias

  6. Hola Jose,

    A decir verdad, cuando actualicé a Ubuntu 10.04, el Avast me dejó de funcionar y no he intentado volverlo a instalar.

    Tenía planeado volver a instentarlo cuando cambie a 10.10, para el cual tengo pensado hacer una instalación desde cero, y no como he venido haciendo desde 8.04, que hago las actualizaciones.

    Saludos!

  7. Muchas Gracias, rápido y limpio 🙂 estaba preocupadillo por las particiones windoz y no veía forma de instalar el avast!!

    Post muy muy útil y recomendado!

Deja un comentario

A %d blogueros les gusta esto: